Forum APRS Polska

Zaloguj się lub zarejestruj.

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
Szukanie zaawansowane  

Aktualności:

Autor Wątek: FOA + Motorola GM900  (Przeczytany 14818 razy)

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
FOA + Motorola GM900
« dnia: Listopad 02, 2009, 19:53:52 LOC »

Witam
Prosiłbym znawców tematu o zerknięcie i zweryfikowanie mojego toku myślenia.
Czy podłączenie w ten sposób pozwoli na podłączenie FOA do Motki  i działanie w trybie APRS.
Zależy mi na tym, żeby w trakcie pracy na aprs nie działał zewnętrzny głośnik, żeby mi nie szumiało w samochodzie. Ewentualnie, żebym mógł zciszyć głośnik bez wpływu na odbierane pakiety.

Mój pomysł na podłączenie jest taki:

http://www.adrianmatusik.com/rozne/foa.pdf

a rozpiska pinów w Motoroli GM900 jest taka:

Pin No.     Description
1.    External Speaker (+)
2.    Internal Speaker (+)
3.    External Speaker (-)
4.    Digital Ground
5.    Busy
6.    Bus +
7.    Ground
8.    Programable Input/Output 8 (CSQ Detect)
9.    Emergency
10.    Analog Ground
11.    Discriminator Audio Filtered Output
12.    AUX RX IN2
13.    External Microphone Audio Input
14.    Switch A+ Sense 0.5 Amps Max
15.    Ignition Control Input
16.    Programable Input/Output 2 (External Alarm)
17.    LH RESET
18.    BUS -
19.    SCI RX DATA
20.    Programable Input/Output 4
21.    Programable Input/Output 3 (External PTT)
22.    RSSI OUT
23.    EXTERNAL MIC IN
24.    AUX TX IN2
25.    Universal Input/Output (Discriminator Audio)

Jakieś opinie, sugestie etc. ??
Zapisane
Adrian VY 73!

SP5QWK

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 253
    • Strona domowa SP5QWK
Odp: FOA + Motorola GM900
« Odpowiedź #1 dnia: Listopad 02, 2009, 20:16:17 LOC »

Pin No.     Description
1.    External Speaker (+)
2.    Internal Speaker (+)

Żeby działał głośnik musisz mieć zwarte te 2 piny. Jeśli ich nie zewrzesz nie będzie działał głośnik. Ewentualnie można przez jakiś switch przerzucić żeby można było w razie potrzeby uruchomić głośnik wewnętrzny.

Bez regulacji wyjście audio jest na pinie 25, ale obawiam się że jest to zbyt niski poziom aby wysterować FOA.

Proponuję podłączyć audio FOA do pinu 3 (Spkr "-" broń Boże do masy bo upalisz radio!) i wyłącznik między pin 1 i 2. Wtedy masz regulację do ewentualnej normalnej pracy przez radio, a do pracy z FOA wyregulujesz sobie na bieżąco.
« Ostatnia zmiana: Listopad 02, 2009, 20:37:50 LOC wysłana przez SP5QWK »
Zapisane

SP3VSS

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1188
  • Nic co tajne nie jest nam obce.
    • http://vss.pl
Odp: FOA + Motorola GM900
« Odpowiedź #2 dnia: Listopad 02, 2009, 20:39:30 LOC »

dźwięk bierz z zwartych pinów 1 i 2, wtedy potencjomentrem możesz ustawić sobie głośność
Zapisane
-
VSS
PZK - Piraci Z Karaibów
http://vss.pl/aprs_digi_igate_wyse_s90

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #3 dnia: Listopad 02, 2009, 21:43:27 LOC »

a te piny 9 i 10 jak pisał Artur odnośnie TT i Motki też trzeba zwierać?
Zapisane
Adrian VY 73!

SP3VSS

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1188
  • Nic co tajne nie jest nam obce.
    • http://vss.pl
Odp: FOA + Motorola GM900
« Odpowiedź #4 dnia: Listopad 03, 2009, 01:07:28 LOC »

ja mam je w mcs2000 zwarte w przemienniku, bez tej zwory nie trybi. poza tym wszytsko ma byc podłączone jak sobie namalowałeś
Zapisane
-
VSS
PZK - Piraci Z Karaibów
http://vss.pl/aprs_digi_igate_wyse_s90

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #5 dnia: Listopad 08, 2009, 13:42:06 LOC »

polutowałem (a w zasadzie pomógł mi bardzo Marcin SP5QWE) podłączyłem i klops.....
Foa ruszył, zfixował się, odbiera ramki prawidłowo a w momencie nadawania, idzie nośna ale bez modulacji.
W czym problem? Wyjście z FOA podłączone jest wg schematu do ext Mic.
Zapisane
Adrian VY 73!

SQ5LTL

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 759
    • sq5ltl
Odp: FOA + Motorola GM900
« Odpowiedź #6 dnia: Listopad 08, 2009, 14:08:52 LOC »

Sprawdź jeszcze wejście bo ja tu widzę tak jak by były 2 sztuki???

13.    External Microphone Audio Input
23.    EXTERNAL MIC IN

Musi na pewno być któreś z tych.
Zapisane
73! Paweł  http://qrz.com/db/SQ5LTL
Echolink.PL http://echolink.pl
"Czysto logiczne rozumowanie nie da nam żadnej wiedzy o realnym świecie" - ALBERT EINSTEIN

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #7 dnia: Listopad 08, 2009, 15:05:35 LOC »

Uruchomiłem.... tadammm !! :)
Dla potomnych czytających wątek.
Wyjście z FOA podłączamy do pinu 13 w Motoroli
Zapisane
Adrian VY 73!

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #8 dnia: Listopad 09, 2009, 23:23:27 LOC »

Jednak nie jest tak różowo jak się zapowiadało.
Peerekiem w FOA jak pokręcę w jedną, to jest strasznie cicho i jak łatwo się domyślić ramki nie są dobierane przez DIGI, a jak pokręcę w drugą, to jest głośniej. Na ucho nie tak głośno jak z ręczniaka i ramki też nie dochodzą. Jak peerek jest ustawiony powiedzmy na 3/4 to dochodzi najwięcej ramek, ale nadal nie jest to 100%
Jak można podbić samą modulację z ramką wychodzącą z Motki?? Maciek BLS zasugerował, żeby zamienić ten 13. pin -    External Microphone Audio Input
na 24. AUX TX IN2
Ktoś ma jakieś doświadczenia z tym do czego ten 24???
Zapisane
Adrian VY 73!

SQ5LTL

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 759
    • sq5ltl
Odp: FOA + Motorola GM900
« Odpowiedź #9 dnia: Listopad 09, 2009, 23:28:12 LOC »

To może być dobry pomysł z AUX,em tylko PR'em zjedź na duł, aby czasem nie zjarać wejścia.
Wygląda na to, że albo byś musiał zastosować wzmacniacz (taki mikrofonowy) w torze m.cz foa - radio, ale to taka partanina.
Sprawdź lepiej to wejście AUX.
Zapisane
73! Paweł  http://qrz.com/db/SQ5LTL
Echolink.PL http://echolink.pl
"Czysto logiczne rozumowanie nie da nam żadnej wiedzy o realnym świecie" - ALBERT EINSTEIN

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #10 dnia: Listopad 14, 2009, 21:28:44 LOC »

jednak trzeba było zajrzeć do Motoroli poprzez kabel i odpowiedni soft. Podbicie modulacji do wartości 210 poprawiło głośność modulacji i ilość odbieranych pakietów jest na tę chwilę dla mnie satysfakcjonująca.
Podziękowania za pomoc dla Roberta SP5UHR i Marcina SQ5LTA za pomoc w lokalizacji i usunięciu niedogodności.
Zapisane
Adrian VY 73!

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #11 dnia: Grudzień 03, 2009, 11:20:00 LOC »

Przygód ciąg dalszy. Od kilku dni pojawiła się dziwna przypadłość... a nawet dwie.
Jedna jest taka, że jak FOA wygeneruje ramkę, to nie wyłącza PTT po. Czyli załącza się nośna, ramka idzie w eter i nośna nadal stoi, a druga to, że po włączeniu FOA odpala się w trybie EMERGENCY! co powoduje sygnał ostrzegawczy w radiach kolegów w okolicy.
Czy to kwestia softu, czy czegoś innego? Wcześniej wszystko było ok.
Zapisane
Adrian VY 73!

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #12 dnia: Czerwiec 18, 2010, 13:12:41 LOC »

Po setkach kilometrów przejechanych z "cichym" FOA i konsultacjach na Tamie z Adamem SP5RZP i Marcinem SQ5LTA wmontowałem w FOAPACKa wzmacniacz mikrofonowy SMD ze wzmocnieniem 11-krotnym. Wczoraj rozpocząłem testy i na ucho ramka jest zdecydowanie głośniejsza. Trochę po plukam ramkami na dniach to okaże się czy montaż wzmacniacza odniósł oczekiwany skutek.
Zapisane
Adrian VY 73!

SQ5AM

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 117
    • Foto Blog
Odp: FOA + Motorola GM900
« Odpowiedź #13 dnia: Czerwiec 30, 2010, 21:01:56 LOC »

Chciałem dodać pewne spostrzeżenie. Po zainstalowaniu wzmacniacza dzieje się coś dziwnego. Jeśli Foa podpięty jest do prądu i przekręcę kluczyk w stacyjce co powoduje załączenie radia i foa, to załącza się foa i wyłącza radio.
Muszę odłączyć zasilanie FOA, odpalić radio i jak ono jest już włączone, to dopiero podłączyć FOA. Jeśli nie zrobię tego w takiej kolejności, to mimo że napięcie do radia jest podane ono się nie włączy. Chyba nie zamotałem aż tak bardzo. Czy ktoś z Was wie czemu coś takiego nastąpiło?
Zasilanie wzmacniacza podłączone jest do zasilania samego FOA.
Zapisane
Adrian VY 73!

SP5RZP

  • *
  • Offline Offline
  • Wiadomości: 760
    • Namiastka mojej stronki.
Odp: FOA + Motorola GM900
« Odpowiedź #14 dnia: Lipiec 01, 2010, 00:39:39 LOC »

Nie znam rozwiązań układowych Motoroli, bo wg mnie to nie jest w żadnym wypadku radio dla krótkofalowca i unikam produktów tej firmy; być może jest tam tak, że jeśli na wejściu mikrofonowym jest jakaś składowa stała to radio na coś czeka i nie załącza się.
Daj może jakiś kondensator rzędu 47 nF między wyjściem tego wzmacniaczyka a wejściem modulacyjnym Motki.
A tak w ogóle to ja na Twoim miejscu bym go wywalił (przedwzmacniacz) i jednak odważył się zewrzeć ten rezystor SMD na płytce FOA  8)
Zapisane