Forum APRS Polska

Zaloguj się lub zarejestruj.

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
Szukanie zaawansowane  

Aktualności:

Autor Wątek: GPS Navibe - czy ktoś traktował młotkiem... ?  (Przeczytany 42910 razy)

sp2nas

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 20
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #15 dnia: Lipiec 27, 2008, 21:58:37 LOC »

To co piszesz, w 100% się zgadza!!! Potwierdziło się to co napisałem wyżej. Ale gdybyś wcześniej nie ustawiał 4800 baud to też by Ci po wylutowaniu baterii tak wyszło... Przy okazji: te małe 3V bateryjki z "wąsami" do lutowania bardzo trudno kupić. Ja wstawiłem tam znacznie łatwiejszą do zdobycia (ale o 2x większej średnicy) baterię CR1220/1VC. Przylepiłem ją do dna pudełka a w szereg włączyłem jeszcze 2 goldpiny z jumperem. Dzięki temu nie muszę w układzie wciąż manipulować lutownicą czy też drakońsko zwierać wyprowadzeń. Jakoś się to zmieściło... Brak bateryki znacznie wydłuża szybki start. Myszka GPS zachowuje się tak, jakby znalazła się w zupełnie nieznanym miejscu i przeprowadza pełną procedurę startową.
Zapisane
73! Wiesiu SP2NAS

SP3WBX

  • *
  • Offline Offline
  • Wiadomości: 577
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #16 dnia: Lipiec 27, 2008, 22:31:31 LOC »

Dla porównania dwie fotki GM 621 po prawej oraz GM 720 po lewej. Zwraca fakt brak ekranowania modułu GPS w 720.

Zapisane
Robert
SP3WBX

sp2nas

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 20
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #17 dnia: Lipiec 28, 2008, 10:20:46 LOC »

Jako ciekawostkę podam, że niektóre moduły GM621 mają wlutowany kwarc 12MHz przy układzie PL2303, a inne nie...
Zapisane
73! Wiesiu SP2NAS

sp2nas

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 20
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #18 dnia: Lipiec 28, 2008, 10:58:14 LOC »

Temat poruszany w tym wątku, ale nieco zakurzony przez inne informacje. Czym przeprogramować chipset SONY CXD2951?
Służy do tego program GPSView 2003. 
Ten chipset występuje m.in.  w "myszce" GPS GM621.
Do programu dostępny jest też w necie manual. Jeśli ktoś będzie miał kłopoty ze znalezieniem to mogę podesłać na priva.
Zapisane
73! Wiesiu SP2NAS

sq6ade

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1564
  • Sheriff's Office
    • http://www.sq6ade.elektroda.eu
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #19 dnia: Sierpień 03, 2008, 19:46:55 LOC »

Cytat: sp2nas
Przy okazji: te małe 3V bateryjki z "wąsami" do lutowania bardzo trudno kupić.

W temacie bateryjki Li . (sory za lekko OT)
Niby nie można lutować wąsów bo jej szkodzi - partyzantke z lutowaniem sprawdzałem pare razy i daje rade. Wystarczy lutownica z dobrą wydajnością termiczną grota (np. klasik Weller).
Można też poszukać w okolicy firmy regenerującej ACCu do wkrętarek.
Bankowo mają mini-zgrzewarkę i "pan Kazio" za piwko bezboleśnie dogrzeje "wąsy".
Zapisane

Krzysiek QRV > 145,250/438.850

SQ5NWI

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 265
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #20 dnia: Wrzesień 11, 2008, 23:51:01 LOC »

Witam!

Spróbowałem skorzystać z informacji w tym wątku, żeby do swojego TM-D710 podłączyć GPS Navibe GM720 i... na razie bez powodzenia.
Tzn. podłączyć się da, ale jeszcze nie działa ;-).

Podłączony przez USB do komputera i potraktowany SiRFDemo zachowuje się grzecznie (komunikuje się z aplikacją, zmienia prędkość transmisji według zadanych ustawień, etc.), ale kiedy wyciągam sygnał sprzed konwertera USB-RS232 to niestety Kenwood go nie widzi, a na porcie szeregowym komputera za pomocą Hyper Terminala widzę coś takiego:

"NN::>>N66N>2N>&N:.NNNNNNNN6F6N6F>N:F>N*6>F::.F*"2NęN>F>>NNćĚ™š,šfćN66N>2N>
&N:.NNNNNNNN6F6.F*"2NęN>F>>NN::>>NNćĚ™š,šfćÓ¦ć¦ĚćĚšćĚ™š,šfćÓ¦ć¦ĚćĚšćĚ™š,šfć¦
N2N6N::N:.N2>N:26N2>N:N6*N>**NN::N:N66N:N26N::N6:N:&V""ĘÖn2N::N6N>N22*NN>

Dodam, że za pomocą tego samego Hyper Terminala na wirtualnym porcie szeregowym odbiornika GPS od strony interfejsu USB widzę coś takiego:

"$GPRMC,210332.000,A,5208.1196,N,02049.5693,E,0.00,,110908,,,A*76
$GPGGA,210333.000,5208.1196,N,02049.5693,E,1,05,1.9,82.7,M,39.3,M,,0000*63
$GPGSA,A,3,19,22,03,06,14,,,,,,,,2.2,1.9,1.0*33

Co może być tego przyczyną?
Niedopasowanie poziomów napięć czy może coś innego?
Jak ten problem rozwiązać i uruchomić GPS na potrzeby APRS w moim TM-D710?
Będę zobowiązany za wszelkie wskazówki.
--
Pozdrawiam!

Krzysiek
SQ5NWI
Zapisane
Krzysiek
SQ5NWI

SP5RZP

  • *
  • Offline Offline
  • Wiadomości: 760
    • Namiastka mojej stronki.
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #21 dnia: Wrzesień 12, 2008, 00:09:03 LOC »

Ja takie "farfocle" widziałem jak ustawiłem złą prędkość portu...
Może tu jest pies pogrzebany?
GM720 (przynajmniej te moje) pracują na 4800 a Kenwood przypadkiem nie potrzebuje 9600?

Poza tym poziomy logiczne mogą się gryźć - próbowałeś przez inwerter na tranzystorze i 2 rezystorach tak jak to w np. TinyTraku się robi?
A jak nie to prosty dzielnik rezystorowy - sygnał z modułu GPS wyprowadzasz przez rezystor 22kohm - drugi koniec tego rezystora do Kena, a dodatkowo między ten drugi koniec rezystora 22 kohm a masę rezystor np. 220 kohm.
« Ostatnia zmiana: Wrzesień 12, 2008, 00:17:37 LOC wysłana przez SP5RZP »
Zapisane

SQ5NWI

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 265
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #22 dnia: Wrzesień 12, 2008, 00:57:06 LOC »

Dzięki za szybki odzew.
Z prędkością portu kombinowałem najpierw.
W Kenwoodzie mogę ustawić jedną z 3 wartości - 2400, 4800 lub 9600.
Nijak nie działa, a te krzaczki, które wkleiłem wyżej zostały odebrane na 9600.
Na innych prędkościach (sprawdziłem od 1200 do 115 200) to co widać w oknie Hyper Terminala jest jeszcze bardziej "pozbawione logiki".

Muszę sprawdzić tą kwestię poziomów logicznych. Dziś już za późno albo raczej za wcześnie. Dam znać, a gdyby do tego czasu ktoś miał jeszcze jakieś sugestie to oczywiście przeczytam z uwagą.
--
Pozdrawiam!

Krzysiek
SQ5NWI
Zapisane
Krzysiek
SQ5NWI

SP5RZP

  • *
  • Offline Offline
  • Wiadomości: 760
    • Namiastka mojej stronki.
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #23 dnia: Wrzesień 12, 2008, 01:02:17 LOC »

Ja Kenwoodem się nie bawiłem (za drogi jak dla mnie), więc w tym względzie niewiele pomogę, ale tymi 2 metodami (same rezystory lub z tranzystorem) udało się podpiąć  GM720 do 3 różnych trakerów APRS, więc i Kenwood musi się poddać. Proszę powalczyć i o efektach (czyli rozwiązaniu problemu) powiadomić tutaj - po co inni mają wyważać otwarte drzwi.
Powodzenia.
Zapisane

sq6ade

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1564
  • Sheriff's Office
    • http://www.sq6ade.elektroda.eu
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #24 dnia: Wrzesień 12, 2008, 09:36:16 LOC »

Kenowi lepiej podać sygnał z konwertera na MAX 232 bo on ma też coś w tym stylu na pokładzie.

Może te krzaki to jakiś protokół binarny właściwy dla tego czipsetu?
Zapisane

Krzysiek QRV > 145,250/438.850

sq6ade

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1564
  • Sheriff's Office
    • http://www.sq6ade.elektroda.eu
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #25 dnia: Wrzesień 13, 2008, 19:41:30 LOC »

Widziałem że na grupie dyskusyjnej zadałeś ten problem i pojawił się pomysł z zafaszowaniem na skutek złej polaryzacji sygnału.
To raczej nie to bo z fragmentu stringu jaki zapodałeś po negacji wychodzą też krzaki i to gorsze bo wychodzą ponad alfanumeryczne znaki ascii.
Zapisane

Krzysiek QRV > 145,250/438.850

SQ5NWI

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 265
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #26 dnia: Wrzesień 17, 2008, 23:42:47 LOC »

Tak, napisałem o tym problemie również na p.r.r.a.
Sprawdziłem dziś to co mogłem zrobić "od ręki" - inwerter na tranzystorze opisywany i tu, i na grupie.
Niestety, jak na razie nie działa, choć kolega, który tam odpisał twierdzi, że sam stosuje takie rozwiązanie.
Może coś zrobiłem źle...
Poczekam na sugestie, a przy braku pomysłu spróbuję dopasowania za pomocą MAX232, który muszę najpierw nabyć :-).
Zapisane
Krzysiek
SQ5NWI

SQ6NTI

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 410
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #27 dnia: Wrzesień 18, 2008, 00:57:56 LOC »

Jeśli GPS ma jakieś wyjście +3.3V, to MAX3232 - będziesz miał z głowy problem zasilania układu. MAX232 chodzi od 4V.
Zapisane
Miłosz SQ6NTI - Wrocław APRS Team - QRV 145.450, SR6WR, 145.250, SR6R

SQ5NWI

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 265
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #28 dnia: Wrzesień 18, 2008, 16:08:08 LOC »

OK, zasilanie to nie problem.
Czy dobrze kombinuję, że wyjście z GPS należy podłączyć do pinów 10 lub 11 układu MAX232, a wejście RS232 w komputerze/radiu do nóżek 7 lub 14?
Potrzebne są jeszcze jakieś elementy dopasowujące na wejściu lub wyjściu z MAXa?
Zapisane
Krzysiek
SQ5NWI

SQ9IWE

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1437
Odp: GPS Navibe - czy ktoś traktował młotkiem... ?
« Odpowiedź #29 dnia: Wrzesień 18, 2008, 21:51:26 LOC »