Forum APRS Polska

Zaloguj się lub zarejestruj.

Zaloguj się podając nazwę użytkownika, hasło i długość sesji
Szukanie zaawansowane  

Aktualności:

Autor Wątek: OT + PeetBros  (Przeczytany 14628 razy)

sq1gpi

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 143
  • th-d7 tm-d710 OT2m
Odp: OT + PeetBros
« Odpowiedź #15 dnia: Listopad 28, 2008, 21:31:40 LOC »

konkretnie to problem wygląda tak:

1. Dane wypluwane przez OT2m są nierozpoznawalne dla odbiorników typu kenwood, podglądam na swoim tmd710 i mam coś takiego  ??SR2WXG  (nawet nie wrzuca tego na liste stacji i nie można zatem zobaczyć żadnych wartości)

2. Lokalne digi powtarzają ramke ale w programach typu UI-V nie ma żadnych wartości w polach danych

3. I na koniec.... jedyne co dekoduje jako tako ramki to TH-D7 - ale on z kolei pokazuje wartości "z kosmosu"

Dziś ze strony producenta załadowałem nowy soft z nadzieją że bedzie lepiej ale dalej jest jak wyżej :-(
 Wrrrr a miało być tak pięknie ( lokalne digi + WX )
Zapisane

SP1QXN

  • *
  • Offline Offline
  • Wiadomości: 457
Odp: OT + PeetBros
« Odpowiedź #16 dnia: Listopad 28, 2008, 21:37:40 LOC »

Kup WS2300 i bedzie OK  ;D

Czy wewnatrz U2100 mozna cos ustawiac? np predkosc przesylu baud etc..? Byc moze to jest powodem wysylania bzdur.
Ja nie moglem kilka dni temu nawiazac polaczenia OT2m z PC.. rozne kombinacje czynilem, podmienialem pliki... cuda na kiju. Na koncu zajrzalem do manuala i przeczytalem ze firmowo predkosc w trybie KISS ustawiona jest na 4800 a ja usilnie katowalem go na 9600  ;D
Zapisane

sq1gpi

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 143
  • th-d7 tm-d710 OT2m
Odp: OT + PeetBros
« Odpowiedź #17 dnia: Listopad 28, 2008, 21:59:34 LOC »

Fakt!!!  wedle instrukcji U2100 ma na porcie 2400 a OT2m 4200. Może to jest źródłem problemu. Tylko dlaczego po pierwsze piszą że OT2m ma 9600 skoro nie ma, a szczytem jest opis że współpracuje z Ultimeter serii 2000 skoro nie jest to do końca prawdą.

Wrrrrrrrr / chce ktoś kupić OT2m?   - mam na zbyciu :P
Zapisane

SP3LYR

  • Administrator
  • *****
  • Offline Offline
  • Wiadomości: 2150
  • Teoretycznie, praktyka pokrywa się z teorią
    • o APRS po polsku
Odp: OT + PeetBros
« Odpowiedź #18 dnia: Listopad 28, 2008, 22:07:07 LOC »

na swoim tmd710 i mam coś takiego  ??SR2WXG
Taka informacja może się pojawiać, kiedy przychodzi ramka z telemetrią. Można sprawdzić, czy tak faktycznie jest poprzez packet monitor. Ramka z telemetrią zaczyna się od T#001 czy z innym kolejnym numerem.
Zapisane
73
Andrzej SP3LYR

SP1QXN

  • *
  • Offline Offline
  • Wiadomości: 457
Odp: OT + PeetBros
« Odpowiedź #19 dnia: Listopad 28, 2008, 22:11:30 LOC »

Gdyby nie mial 9600 to nie wspolpracowalby z garminem...
Jak jest default to OT2m ma 4800. Ale mozna to przestawic przez terminal... opcje to: 1200,2400,4800,9600,... ....115200
Sprobuj zamieszac z tymi predkosciami i powinno byc OK.
Zapisane

sq1gpi

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 143
  • th-d7 tm-d710 OT2m
Odp: OT + PeetBros
« Odpowiedź #20 dnia: Listopad 28, 2008, 23:42:33 LOC »

Zgadza się to co piszesz Andrzeju, wygląda na to że OT2 nie trawi danych z U2100. Przerobiłem wszystkie możliwe prędkości portu i formaty danych... nic z tego nie wyszło. Może w przyszłości coś się zmieni  w oprogramowaniu, lub ktoś mądrzejszy coś wymyśli - proszę wówczas o info.
Zapisane

SP3VSS

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1194
  • Nic co tajne nie jest nam obce.
Odp: OT + PeetBros
« Odpowiedź #21 dnia: Listopad 29, 2008, 09:04:25 LOC »

Tu zapis 3 minut tego co nadaje ws2300:

http://www.vss.user.icpnet.pl/ws2300.txt

prędkość jednak 2400bd, z niecierpliwością czekam na translator.
Zapisane

SP1QXN

  • *
  • Offline Offline
  • Wiadomości: 457
Odp: OT + PeetBros
« Odpowiedź #22 dnia: Listopad 29, 2008, 10:28:06 LOC »

Rozumiem ze sprawa podlaczenia OT2m pod radio rowniez zostala sprawdzona? Dewiacja? Zworka na HI lub bez i zworka na +5V albo bez niej?
Zapisane

sq1gpi

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 143
  • th-d7 tm-d710 OT2m
Odp: OT + PeetBros
« Odpowiedź #23 dnia: Listopad 29, 2008, 10:58:54 LOC »

ufff o 3:30 wszystko ostatecznie zatrybiło i teraz działa, jednak nie do końca tak jak to było w ot+.
OT2m akceptuje inny format danych z urządzeń Ultimeter. Do tej pory używałem na wyjściu "COMPLETE RECORD MODE" i tego właśnie OT2m nie rozpoznaje. Należy przestawić na "DATA LOGGER MODE" i jest w miarę ok - to rozwiązanie ma jednak minus bo nie podaje wartości "Gust". Dziś jeszcze pozmieniam to i owo, może coś uda się dopracować.
Zapisane

SP1QXN

  • *
  • Offline Offline
  • Wiadomości: 457
Odp: OT + PeetBros
« Odpowiedź #24 dnia: Listopad 29, 2008, 11:02:48 LOC »

Zawziety czlowiek    ::) Najwazniejsze ze z sukcesem.
Zapisane

SQ9MDD

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 231
  • ...przede wszystkim nie zakłócać...
    • SQ9MDD
Odp: OT + PeetBros
« Odpowiedź #25 dnia: Listopad 29, 2008, 11:26:57 LOC »

Tu zapis 3 minut tego co nadaje ws2300:

http://www.vss.user.icpnet.pl/ws2300.txt

prędkość jednak 2400bd, z niecierpliwością czekam na translator.

Na pierwszy rzut oka wygląda jakby prędkość była inna niż w konfiguracji bo jakieś krzaki tutaj widać.
Opis ramek jakie wyrzuca twoja stacja pogodowa bardzo by się przydał.

A wracając do tematu, skopiowałem jeden rekord z tych  które wystawił Andrzej (dzięki wielkie). Oprogramowałem 16F84 tak by wyrzucał mi ten rekord co jedną sekundę na RS-a (prędkością 2400 8N1)
Podpiąłem to wszystko razem z OT+.

No i działa. OT mruga na zakończenie ramki z danymi i wysyła dane na radio (znaczy po kablu do kompa ;) )
No to kombinuję dalej...
Zapisane

sq1gpi

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 143
  • th-d7 tm-d710 OT2m
Odp: OT + PeetBros
« Odpowiedź #26 dnia: Listopad 29, 2008, 12:37:20 LOC »

U mnie tez działa i wypluwa wszystkie dane, Żeby akceptowało "complete record mode" musiałem załadować starszy firmware. Teraz już działa  100%.

Podsumowując:
ustawienie portu a lub b (w zależności od tego  gdzie podłączymy ) trzeba ustawić ręcznie  na 2400
format danych z Ultimetra na "complete record mode"  lub  "data logger mode" (tu nie będzie porywu wiatru) I nie ładować firmwaru, który jest na stronie Argentdata. U mnie dopiero zatrybiło w pełni na pierwotnej wersji oprogramowania.

Z OT+ sytuacja wygląda podobnie, z tym że do urządzenia należy załadować oprogramowanie dedykowane pod dany model WX.

Pozdrawiam wszystkich i życzę powodzenia w konfiguracjach.
Zapisane

SQ9MDD

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 231
  • ...przede wszystkim nie zakłócać...
    • SQ9MDD
Odp: OT + PeetBros
« Odpowiedź #27 dnia: Listopad 29, 2008, 13:02:07 LOC »

Pewnie się powtarzam... ale czy zamiast COMPLETE RECORD MODE mogę zastosować inny format na przykład DATA LOGGING MODE? dane wysyłam do OT+
Zawsze to 13 pól w rekordzie do obrobienia a nie 115. Czy może lepiej zastosować COMPLETE RECORD MODE i spróbować tak po prostu obciąć dane które mnie nie interesują.
W każdym razie zrobię test i zobaczymy, ale sugestie mile widziane.


UPDATE:

Zrobiłem test, wysyłam nagłowek COMPLETE RECORD MODE i tylko te pola które mnie interesują, to działa OT generuje ramkę z danymi które do niego wysłałem. Oczywiście dane do OT wysyła PIC 16F84.
Mała analiza pierwszych trzynastu pól rekordu przykładowego:

&CR&006200420088004D02D402D400002784FFDD8DA9000103220117----01750066042D02400182                                                                               
025F014200660240018202400182025F01420066024001822784041A006200422751011400652751                                                                               
0114032200B1032501640064030B042B00B603E4010A0419006600B603E403F2000003F200000064                                                                               
000003E4011802D401830214006501830214030E03D40065002802F003B70066030E03D427C901BC                                                                               
27C50551006627C901BC03570000036A03B10065036A03B101F901D4028D00AE0065028D00AE0000                                                                               
00000000000000640000042B00000064000200020000ACB6B645005C



0. &CR& //nagłówek COMPLETE RECORD MODE
HEX    DEC   DATA
1. 0062 = 98 * 0.1 = 9,8km/h //predkosc wiatru
2. 0042 = 66 * 1,41176 = 94 DEG //wartość w DEC od 0-255 mnożymy * 1,41176 by uzyskać 360 stopni
3. 0088 = 136 * 0.1 = 136km/h //ostatnie 5 minut predkosc wiatru
4. 004D = 77 * 1,41176 = 108 DEG //ostatnie 5 minut kierunek wiatru wartość w DEC od 0-255 mnożymy * 1,41176
5. 02D4 = 727 * 0,1 = 72,7 F //Wind chill F
6. 02D4 = 727 * 0,1 = 72,7 F //temperatura zewnetrzna F
7. 0000 = 0 * 0.01 = 0,0 //Opad dzienny
8. 2784 = 10116 * 0,1 = 1011,6 mbar //ciśnienie w mbar
9. FFDD = 65501 * 0,1 = 6550,1 mbar //ciśnienie wartość delta mbar
10. 8DA9 = 36265 //korekcja barometru LSW
11. 0001 = 1 //korekcja barometru MSW
12. 0322 = 802 * 0,1 = 80,2 F //temp wewnętrzna
13. 0117 = 279 * 0,1 = 27,9 % //wilgotność zewnętrzna


« Ostatnia zmiana: Listopad 29, 2008, 13:35:57 LOC wysłana przez SQ9MDD »
Zapisane

SP3VSS

  • PG APRS
  • *
  • Offline Offline
  • Wiadomości: 1194
  • Nic co tajne nie jest nam obce.
Odp: OT + PeetBros
« Odpowiedź #28 dnia: Listopad 30, 2008, 13:11:34 LOC »

Na pierwszy rzut oka wygląda jakby prędkość była inna niż w konfiguracji bo jakieś krzaki tutaj widać.
Opis ramek jakie wyrzuca twoja stacja pogodowa bardzo by się przydał.


hmmm, dziwne, moge ponagrywac z innymi prędkościami. uzywam programu "serial port monitor". może uzyc jakiegoś innego ??
Zapisane

SP1QXN

  • *
  • Offline Offline
  • Wiadomości: 457
Odp: OT + PeetBros
« Odpowiedź #29 dnia: Listopad 30, 2008, 14:51:59 LOC »

WS2300 na 100% wywala dane na 2400baud.
Zapisane